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Drag and Drop - Try Again [advanced]
This page explains how to use multiple advanced actions to produce a Try Again message for the first (or more) incorrect attempts, and a final 
Incorrect message for the last attempt.

This page assumes you already have a drag and drop interaction with drag sources and drop targets already set up. It only deals with the 
Submit / Try Again / Incorrect elements. It also assumes you have click boxes on all slides, so they don't automatically advance. If you have 
your course set up to auto-advance, put a click box on this slide and let users know they have to click the Forward Arrow to continue.

FYI, you can save the Advanced Actions you'll be creating as , which means you can use them for other projects. This means Shared Actions
you only have to set them up from scratch once.

Table of Objects Created or Mentioned on This Page
Relevant Drag and Drop settings:
Create a variable to limit attempts
Create an incorrect answer object
Create a Try Aagin button
Create a reset slide
Create the Advanced Action
Create TryAgainButton Advanced Action
Add Action to TryAgain Button
Create Action to trigger slide audio
Create and assign Correct answer audio

Table of Objects Created or Mentioned on This Page

The "ID" in each name would be customized for each interaction. E.g., for one DragDrop interaction that includes all of the objects below, ID 
would be replaced by "workflow" or "approvals" for every object – Attempts_workflow, IncorrectFeedback_workflow, etc. This is so every object 
is identifiable as part of that particular DragDrop interaction.

Name Type Purpose Screenshot

Attempts_ID variable

(value = 2, for one chance to try 
again)

This is the number of attempts 
remaining for an interaction. It 
decrements every time the slide is 
entered. What each value triggers:

2 = initial state with slide audio

1 = Try Again state

0 = Incorrect Feedback state

IncorrectFeedback_ID caption, shape, or image This displays the feedback of the 
correct answer after the last attempt 
has been exhausted.

IncorrectFeedback.wav  OR
HowParagraphShouldRead.wav

audio Audio file attached to above 
IncorrectFeedback_ID caption, 
shape, or image. The audio can be 
generic, e.g., "That's not correct. 
Here is how the paragraph should 
read" or "Here is the correct 
answer." This is why there is no 
"_ID" attached to the file name. It 
can be used for any Drag and Drop 
interaction.

Add audio in the Options tab of the 
Properties panel of the feedback 
object:

  OR

https://helpx.adobe.com/captivate/using/shared-actions.html
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TryAgainButton_ID button This appears when the user has at 
least 1 attempt left. It triggers an 
action of re-entering the slide.

This button triggers an advanced 
script, so the Properties > Actions 
panel for the button looks like this:

TryAgain.wav audio Audio file attached to 
ButtonTryAgain (this can be 
generic, e.g., "That's not correct. 
Click here to try again.")

Reset slide Captivate slide This .1 second slide is blank and 
allows the user to re-enter the drag-
and-drop slide fresh.

Duration is set to .1 sec in Timing 
panel.

Add this invisible object to let others 
know to delete the slide.

title it warning note and hide it
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TryAgain_ID Advanced Action This complex action has three parts 
– one to decrement the Attempts_ID 
variable, one to trigger the try again 
state, and one to trigger the 
incorrect final state.

Here are all three tabs created:

How it's called into action (Drag and 
Drop panel >Actions tab > Execute 
Advanced Action script):



Content on these Oracle Cloud Infrastructure pages is classified Confidential-Oracle Internal and is 
intended to support Oracle internal customers & partners only using Oracle Cloud Infrastructure.

Page: 4

TryAgainButton_ID Advanced Action This action sends Captivate to the 
previous slide (the reset slide) and 
hides the Try Again button on the 
main slide, so the user sees the 
drag and drop fresh.

how it's created:

how it's triggered in the Properties > 
Actions panel of the button itself:

DragDropAudio_ID Advanced Action This action triggers the slide audio 
ONLY for the first time the user 
sees the slide (when the 
Attempts_ID is set to its maximum, 
e.g. 2). This way, when they re-
enter the slide to try again, they 
don't hear the slide introduction a 
second time.

How it's created:

How it's called into action. On the 
main slide Properties > Actions 
panel, On Enter:

4-DragDrop.wav

(4 is whatever the slide # is)

audio This is the main audio for the slide, 
which is triggered by the Advanced 
Action above. There is NO slide 
audio attached to the slide in the 
usual way (in the timeline), because 
it would play every time, and we 
don't want that.

(same as above)

Correct.wav audio If you have Try Again and Incorrect 
audio, you should also have audio 
that plays for the correct answer 
feedback. Be consistent.

Assign this audio to the Success 
Shape (correct button) in the 
Options panel:
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Relevant Drag and Drop settings:

On Success: Continue (default)
On Failure: Execute Advanced Actions (this will come later – you'll create the script)
No. of Attempts: 1 (even though they will have more than one – trust me!)
No infinite attempts, no failure caption (uncheck them if checked – you're going to create a custom failure caption instead of using this 
option)
Success caption checked (default)

Create a variable to limit attempts

Create a variable and assign the value equal to the number of attempts you want to give people. Go to Project > Variables.

Click Add New. Name it Attempts_ID, add a value (2 or 3, for the number of attempts you want) and a description.

Note that all advanced actions and variables throughout the entire project are listed in your Advanced Actions and Variables panels, so name 
them not just according to their function, but also according to the content of that particular slide. If you have several drag and drop interactions 
where you want to give the user multiple attempts, name them like this: Attempts_workflow, Attempts_approvals, etc., where the final word 
relates to that slide topic. Do this for all objects that you name.
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Create an incorrect answer object

Create a caption that explains the answer, or an image that displays the proper answer, whatever. Examples:

or

Something more than just "That's Incorrect" is preferable, especially since drag-and-drops are complex actions.

Name it wisely, and make it INVISIBLE by default (click the eye). It will only be made visible after the user clicks Submit on the  attempt.last

Add audio to this object in the Properties > Options area. It can be generic audio like, "That's incorrect. Here is the correct answer" that you 
can use for any slide. In that case, it doesn't have to be named more specifically than "IncorrectFeedback.wav."

Create a Try Aagin button

Go to Interactions and create a button that users click to Try Again. This will appear after the get the wrong answer,  for the last attempt.except
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Give it a good name (you'll need to find it when creating an Advanced Action) and make it invisible by default (click the eye):

Make it transparent, so you can alter the colors. Enter "That's not correct. Click here to try again." (or whatever you want) into the Caption area:

Make the the color and text are proper for Redwood (this is the mustard color, E4BD82).



Content on these Oracle Cloud Infrastructure pages is classified Confidential-Oracle Internal and is 
intended to support Oracle internal customers & partners only using Oracle Cloud Infrastructure.

Page: 8

Final result:

Add audio to the button just like you did for the incorrect feedback object. Click on the button and in the Options tab, click Add Audio, then 
select the file. You can create one generic "That's not correct. Click here to try again" file, and use it for all Try Again buttons.

Create a reset slide

Create a blank slide with a duration of  seconds just before the drag and drop slide. Make sure there is no click box preventing it from auto-.1
advancing. This is a tricky way to force Captivate to reset the drag and drop interaction and return it to its initial state. This will make sense later.

You can also add a note on the slide that says not to delete it – for others' (and your own) reference.

Make sure the note is set to invisible, so it won't show up in the course!

Create the Advanced Action

This is where the magic happens. Open the Advanced Actions tab in the Project menu.
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You'll see three untitled tabs representing decisions.

Name the Action something meaningful (DragDrop_ID or TryAgain_ID) and name the three tabs (double-click to edit the names): Always, 
TryAgain, and IncorrectFinal.

Check the Conditional tab box to make the IF / ELSE tables appear.

Recreate the three decisions below. They show the Try Again button for the first attempts, and hide it in order to show the Incorrect message for 
the final attempt. Each time the user clicks Submit, the Attempts_ID variable decreases by 1. When it hits zero, the Incorrect message appears.

When entering the advanced actions, the things you act on are either literal (the actual number of attempts) or variable (Attempts_ID or other 
created variables).
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If you choose incorrectly, you have to delete the line of instructions and begin again. Captivate is picky. The garbage can icon is your pal.

Create the  advanced action (so named because this action happens every time). The 1 and 1 are literal values, not variables. Double-Always
click inside the first line, and select literal, then type 1. Set it equal to the literal value 1. Then create the two Actions (Decrement the 
Attempts_ID by 1, and Hide the TryAgainButton_ID).
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Create the  action (this only happens when Attempts_ID is greater than 0). Attempts_ID is a variable, and 0 is literal. The Action is to TryAgain
Show TryAgainButton_ID.

Create the  IF and action sections (this happens at the last attempt only).IncorrectFinal
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Save that Advanced Action. Now we're going to create another one.

Create TryAgainButton Advanced Action

In the Advanced Actions window, click the  sign to create a new action.+

Name it TryAgainButton_ID. No conditional tab is needed. Enter these actions to hide the TryAgainButton you previously created.

Save the Advanced Action, and close the Advanced Actions window.

Add Action to TryAgain Button

Click the TryAgain button on the slide, and go to the Properties > Actions panel. Choose these options:

On Success: Execute Advanced Actions
Script: TryAgainButton_ID
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This will trigger an action when the button is clicked. Captivate will go to the previous slide (which resets the drag and drop interaction, though 
the users won't notice the slide, as it's only .1 seconds long) and hide the Try Again button.

Now go back to the Drag and Drop panel and update the actions tab On Failure option. Choose Execute Advanced Actions, and select the one 
you created.

Create Action to trigger slide audio

You don't want the slide audio to play again when the user tries the interaction again, so we set an Advanced Action to have it only play when 
the Attempts_ID is set to its maximum number, e.g. 2. This will keep the audio from playing again when it gets decremented to 1 and 0. First, 
delete the slide audio from the timeline, if it's already there. Then, create the following Advanced Action: If the Attempts_ID variable is equal to 2 
(its original value), play the slide's audio.
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Then set that Advanced Action to happen upon entering the slide. In Properties > Actions > On Enter. Choose Execute Advanced Actions, then 
find that audio action.

Create and assign Correct answer audio

You can use a generic Correct message. Add it the same way you have the others. Click the object (titled Success_Shape by default), and add 
the .wav file. Make sure the success shape is properly formatted (it should be, if it's the Redwood template – Oracle Sans text on green).
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That's it!

An example of this interaction is in .downloadable from OraDocs

This tutorial was customized from other combined tutorials that you might find helpful if you want to create variations on this.

http://blog.lilybiri.com/custom-failure-messages-slash-attempts-drag-and-drop

https://elearning.adobe.com/2017/01/multiple-failure-messages-for-dragdrop-kc-slide/

https://community.adobe.com/t5/captivate/how-to-set-up-multiple-attempts-in-drag-and-drop/m-p/10854420#M276855 (my initial question to the 
community)

https://oradocs-corp.documents.us2.oraclecloud.com/documents/link/LD79B9A4F2ED279FB389E513F6C3FF17C1177A968060/fileview/D90D1138DA98345828F78788F6C3FF17C1177A968060/_TryAgainExample.cptx
http://blog.lilybiri.com/custom-failure-messages-slash-attempts-drag-and-drop
https://elearning.adobe.com/2017/01/multiple-failure-messages-for-dragdrop-kc-slide/
https://community.adobe.com/t5/captivate/how-to-set-up-multiple-attempts-in-drag-and-drop/m-p/10854420#M276855
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